Error with opam install

When I try to install any package with Opam, i.e.

$ opam install why3

I receive the following message:

[ERROR] Solver failed: “/usr/bin/aspcud
exited with code 1 “ERROR: grounder returned with non-zero exit status”

Somebody can help?

Thank you

I just tried a:

$ ls -al /usr/bin/aspcud
ls: cannot access '/usr/bin/aspcud': No such file or directory

and then I did:

$ opam install why3
The following actions will be performed:
  ∗ install why3 1.2.1

<><> Gathering sources ><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[why3.1.2.1] downloaded from cache at

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
∗ installed why3.1.2.1

So, all I can say is that I have coq 8.10.2 installed - probably best to contact the why3 group

This looks like a solver failure, this might be an opam bug. What version of opam and aspcud are you using and on what system/distribution?

Try opam --solver=mcss install why3 to see if this is an aspcud issue.

The problem has been solved by reinstallation of the last versions of apscud and opam. Many thanks.

Great! Since opam 2.0, the solver is embedded, you should no more need an external aspcud (unless you choose to use an external solver).