Install Ocsigen

lwt
opam
ocsigen

#1

Hi,

I do opam install eliom (after opam upgrade) and I receive :
The following dependencies couldn’t be met:

  • ocsigenserver -> lwt < 3.0.0
    Your request can’t be satisfied:
  • No package matches lwt<3.0.0.

No solution found, exiting

And opam show lwt says :
package: lwt
version: 3.1.0
I started with Ocaml and Opam yesterday, I prefer to ask advice.

Thanks


#2

IIRC this looks like an error message from the broken internal solver. Could you please report the output of opam config report.


#3

Thanks for your attention.

# OPAM config report
# opam-version    1.2.2 
# self-upgrade    no
# os              linux
# external-solver no
# criteria        -removed,-notuptodate,-changed
# jobs            4
# repositories    3* (http)
# pinned          0
# current-switch  system*
# last-update     2017-08-22 20:46

#4

opam is no longer able to function correctly on the current opam OCaml respository with the internal solver (it will be removed in the next version of opam). You will have to install an external solver, see here.


#5

Thanks !

I have done sudo apt install aspcud

Could you give me the command line ?


#6

i try with
opam install eliom --solver=aspcud


#7

AFAIK you should not have to do anything. Just check that opam config report reports an external solver.


#8

Just

 dbm.1.0 troobleshooting =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
=> This package relies on external (system) dependencies that may be missing. `opam depext dbm.1.0' may help you find the correct installation for your system.

and opam config report :

# OPAM config report
# opam-version    1.2.2 
# self-upgrade    no
# os              linux
# external-solver aspcud $in $out $criteria
# criteria        -count(removed),-notuptodate(request),-sum(request,version-lag),-count(down),-notuptodate(changed),-count(changed),-notuptodate(solution),-sum(solution,version-lag)
# jobs            4
# repositories    3* (http)
# pinned          0
# current-switch  system*
# last-update     2017-08-22 20:46

#9

@mico, I think you should use triple backticks for pasting reports and code:

```
code or report
```

That will preserve formatting.


#10

Good so there’s no need for you to specify the --solver=aspcud I hope you managed to get some things installed…

Try

opam install depext 
opam depext dbm

which will help to install the needed dependencies on your system.


#11

I works fine. Thank you very much for your attenion

An other problem :slight_smile:
opam install ocsigen-start
[ERROR] ocsigen-start is not available because your system doesn’t comply with ocaml-version >= “4.03”.

I have indeed OCaml version 4.02.3
I installed ocmal with apt-get and then coq and then coqide (hard work).

If i remove ocaml with apt-get purge before to install the latests version of caml, there is a risk for coq and coqide ?


#12

You can just leave your system install of ocaml in peace and use another switch for ocsigen do

opam switch 4.03.0
eval $(opam config env)
opam install ocsigen-start

#13

done thanks

it is like virtualenv in Python ?


#14

Thank you :slight_smile:


#15

the last step :wink:

mchl@shemesh:~/ocaml/ocsigen$ eliom-distillery -name myapp -template os.pgocaml
The program 'eliom-distillery' is currently not installed. You can install it by typing:
sudo apt install eliom
mchl@shemesh:~/ocaml/ocsigen$ opam install eliom
[NOTE] Package eliom is already installed (current version is 6.2.0)

#16

Maybe a missing eval $(opam config env) in your shell.


#17

not at all : i followed the instructions


#18

Sorry I can’t help further then as I don’t know about eliom maybe the eliom-distillery tool is distributed by another package.


#19

:sunny: thank you very much and have an nice day :slight_smile:


#20

A bit more powerful:

  • You can have a specific OCaml compiler version as well as associated libraries for each of your projects
  • You can alias a switch (give it a specific name) so that it’s easy to remember
  • Upcoming opam version will allow you to automatically install the specific compiler and library versions for a project when you download the project and start working on it.