[ANN] Gopcaml-mode and Gopcaml-mode merlin (0.0.6) - Phoenix release (Support for OCaml 4.14.0!)

Like the phoenix, Gopcaml-mode rises again from the ashes!..

…this time with support for OCaml 4.14.0 and OCaml 4.13.0 (by popular demand)

See the original release post for detailed instructions on how you can install it.

Screenshots (if you haven’t seen them before)

gopcaml_full_syntax_support

gopcaml_move_expression_example

Video

What’s next?

  • Support for OCaml 5.0
  • Better ergonomics for piping (i.e _ |> _)
  • … you decide! (feature requests/pull requests welcome!)
10 Likes

Also, big thanks to the Merlin team for making the internal merlin libraries publically accessible under the merlin-lib package, as now Gopcaml-mode-merlin no longer needs to vendor a custom version of merlin to access them.

3 Likes