Merlin still not running on 4.06?

merlin

#1

I note that merlin won’t build under opam in 4.06. The opam file says:

available: [ocaml-version >= "4.02.1" & ocaml-version < "4.06"]

Is there a good reason that it is specified as < "4.06"?

(This is the last big package I need working to upgrade to 4.06. :slight_smile: )


#2

There is a work-in-progress branch at https://github.com/ocaml/merlin/tree/ocaml_406-wip .

Merlin is much more aware of the compiler’s internals than most user packages and libraries and requires significantly more work to port to new compiler versions than most OCaml software. I don’t know of a list of outstanding work that needs to be done on Merlin (and I’m nowhere near qualified to guess at what it would be myself), but if you’re interested in helping the project along, do say so and perhaps you can get in in time for 4.07 :slight_smile: