Using lablgtk on macOS, gtk2 or gtk3?

Hello. I am once again attempting to use lablgtk on macOS. I’ve been using lablgtk indirectly through Kenichi Asai’s Universe library for several years. It worked fine on macOS for the first few years, but stopped working last year so I had to resort to running Asai’s Universe library on an Ubuntu VM. It wasn’t great.
By “stopped working” I mean that it had 3 problems:

  1. I could not install lablgtk on macOS
  2. The system would hang;
  3. I would receive the warning:

WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It
should not be used in new applications. Use convertRectToBacking: instead.

This year I’ve made a simpler version of the Universe library. Problem .1 seems to be gone but problems 2. and 3. remain. I don’t know if they are related to one another (I doubt it). My package has one module that depends on lablgtk2, and two modules that depend on cario2-gtk.

Somewhere along the line, someone suggested that “gtk hanging” problem is fixed in gtk3. I have no idea if this is correct or how to replace gtk2 with gtk3. As I understand it, cairo2-gtk seems to use gtk2 rather than gtk3. I would greatly appreciate some guidance on this.
Thank you,
Bob Muller

I am answering my own question based on an email interaction with Jacques Garrigue. My problem was related to having installed lablgtk using homebrew. When I installed it using macports:

sudo port install lablgtk2

It all worked correctly.