Sorry, no solution found: there seems to be a problem with your request


trying to install a local package with opam install . (which used to work) I now get:

Sorry, no solution found: there seems to be a problem with your request.

ocaml version is 4.12, opam is 2.0.5

Doing just dune build @install works.

Any idea on where to look for debugging this issue?

That looks like an opam bug @AltGr is working on fixing: [opam 2.1~beta] Surprising conflict message · Issue #4373 · ocaml/opam · GitHub

Could you provide the public repository or a partial opam file if the project isn’t open source?

thanks a lot for the link. Indeed, it seems to be a dependency problem. The package is GitHub - sanette/bogue: GUI library for ocaml based on SDL2, the problem was the line:

(tsdl-image (= 0.1.2))

indeed, I made some local changes to make bogue compatible with tsdl-image 0.3 and I didn’t realize it broke the compatibility with tsdl-image 0.1.2.

If I replaced the above line by
(tsdl-image (>= 0.1.2))
then it works. I’m not sure I understand everything there, but I guess here it was essentially my bad.

I guess if the error message were more informative, if would be of great help.

oh, actually I misread and assumed you were using opam 2.1.0.
2.0.5 is getting quite old (2 years old). Could you retry with the latest version?

It’s easily installable with:

bash -c "sh <(curl -fsSL"

thanks, indeed, it’s much better with opam 2.1.0, since I now get the following error message

[bogue.20210908] synchronised (no changes)
[ERROR] Package conflict!
  * Missing dependency:
    - tsdl-image = 0.1.2
    not available because the package is pinned to version 0.3.0

No solution found, exiting

which is much more informative :wink: