Getting dependency error on running 'opam install opam2web'

Hey There!
I am trying to install opam2web through ‘opam install opam2web’.
Now, opam is already installed.

Following are the versions that I have for each dependency which I’ve checked by running opam list:
cow 2.4.0
opam-lib 1.3.1
js_of_ocaml 3.9.0

This is what I’m getting on running ‘opam install opam2web’.:
Screenshot from 2021-04-23 19-39-22

Since I’m a beginner at using Ubuntu, can somebody please tell me how to unlock base as instructed or if there’s a different solution to this too?


It seems that your command tries to install an old version of opam2web. Could you try opam update first ?
If it still doesn’t work, try opam install opam2web.2.0 and see if it gets you better error messages.

Oh yes!
This time the problem is only with one dependency:

The following dependencies couldn’t be met:
opam2web → js_of_ocaml < 3.3.0 → ocaml < 4.08.0
base of this switch (use `–unlock-base’ to force)

Apparently the js_of_ocaml constraints are fixed in the dev repo, but no release has been made since. You could either gently ping the maintainers for a release (GitHub - ocaml-opam/opam2web: A tool to generate a website from an opam repository) or install the development version (opam pin add opam2web --dev-repo).

1 Like