Does anybody have `tsdl` working on mingw64?

I’m trying to install tsdl on windows, without success (tests are failing to run).

I’m using : ocaml-variants.4.12.0+mingw64c switch.

Anybody here having success with this, before I enter in the details of my convoluted attempts?

cc @dbuenzli

tests are failing to run

that seems a bit weird. Are you using opam install -t or --with-test ?

I did opam source tsdl.
And tried (from memory): ocaml pkg/pkg.ml build --tests true.
But before detailing all the other tries I performed, I’d like to know if anybody has it working?

If people were in the habit in saying what exactly doesn’t work, it would be quite helpful and less time consuming. Has the art of bug reporting been lost ?

OK. Fair enough.

My side question was just to assure that tsdlis supposed to work with ocaml-variants.4.12.0+mingw64c, precisely to avoid a long description of what I tried so far, and others to lose there time…

From your comment, I can only suppose that it is supposed to work.

I’ll revert all my attempts and will start again from the beginning, describing what I’m doing, then.

Best regards.

I know nothing about this ming64c variant, so I can only suppose that it supposed to work :–)

In any case make sure you have the required sdl (i.e. at least 2.0.9), there has been this odd bug report from people who didn’t have the right SDL version.