Cohttp-mirage dependency issues

I’m trying to update the dependencies for a library. It currently uses cohttp-mirage to serve out http endpoints.

The issue is that on ocaml-base-compiler.4.08.0 I am getting constraints for example:

cohttp-mirage → conduit-mirage >= 2.0.2 → tls >= 0.8.0 → nocrypto >= 0.5.4 → ppx_sexp_conv < v0.11.0 → ocaml < 4.03

This is on a new opam switch create test ocaml-base-compiler.4.08.0 switch, so I’m unsure whether just cohttp-mirage hasn’t been updated recently, or whether there is some issue with the dependencies that I’m unable to see (since I can’t work out how nocrypto >= 0.5.4 -> ppx_sexp_conv < v0.11.0 arises).

you’ve chosen a version of OCaml which is not compatible with nocrypto (see – try either a newer (4.08.1 / 4.09.0) or an older one instead.

1 Like

Ah ok, didn’t realise that there was a 4.08.1 release. Thanks!