Trying to install cohttp-lwt-unix-ssl with opam

Hello, I am trying to install the opam package cohttp-lwt-unix-ssl, but I run into the following error:

The following dependencies couldn't be met:
  - cohttp-lwt-unix-ssl → cohttp-lwt >= 3.0.0 → cohttp >= 3.0.0
      unmet availability conditions: false

No solution found, exiting

When I run opam list -a |grep cohttp |head -3, I get the following result:

cohttp                                          2.5.4        An OCaml library for HTTP clients and servers
cohttp-async                                    --           CoHTTP implementation for the Async concurrency library
cohttp-lwt                                      --           CoHTTP implementation using the Lwt concurrency library

It seems that the cohttp package is 2.5.4. I see on github that cohttp 3.0.0 has been released last month. How can I proceed to install cohttp-lwt-unxi-ssl ?

1 Like

Take a look at – cohttp 3.0 is released but marked as unavailable, there’s quite some work on conduit ongoing (used by cohttp) --> soon there’ll be another release.

IIUC in the 2.x series, cohttp-lwt-unix together with a conduit-lwt-unix and lwt_ssl installed should result in a cohttp server implementation capable of doing TLS handshakes with openssl (if you install tls instead of lwt_ssl, the OCaml-TLS stack will be used instead of openssl).