Solved: Ppx_yojson_conv error using Merlin?

Has anyone seen this error while using merlin? This happens when I’m trying to do auto complete on a particular file. I don’t know what, if anything, is special about the file.

Cannot load ppx_yojson_conv: execution of module initializers in the shared
library failed: (Failure "Ppx_deriviers.register: \"of_yojson\" is already

I’m using merlin 4.2-412

Edit: On second look, I think it’s happening when I’m saving the file.

So I’m not quite sure, but I think this is because of something merlin is doing while processing my project, not merlin directly trying to do something with ppx_yojson_conv?

Whoops, user error, I guess.

I have a monorepo and one of my parts of the monorepo was using ppx_yojson_conv, and the others using ppx_deriving_yojson, and after upgrading merlin it looks like it handles this situation differently than the previous version I was on and there was a conflict. I factored out the ppx_yojson_conv to use ppx_deriving_yjson (I don’t even remember why I did this in the first place) and problem solved.