Opam update to 2.0.0-rc


#1
➜  ~ opam list        
# Installed packages for system:
base-bigarray        base  Bigarray library distributed with the OCaml compiler
base-bytes           base  Bytes library distributed with the OCaml compiler
base-threads         base  Threads library distributed with the OCaml compiler
base-unix            base  Unix library distributed with the OCaml compiler
conf-m4                 1  Virtual package relying on m4
conf-which              1  Virtual package relying on which
jbuilder       1.0+beta20  Fast, portable and opinionated build system
ocamlfind         1.7.3-1  A library manager for OCaml
➜  ~ opam --version   
1.2.2
➜  ~ pacman -Q opam   
opam 2.0.0-1
➜  ~ 

My package manager, with which I build opam, shows me the new version. Opam itself is still on 1.2.2. The homepage here writes something about adjusting the path, without one single word about which path. https://opam.ocaml.org/blog/opam-2-0-0-rc/


#2

Curious, how did you install opam the first time? Wouldn’t removing it work?


#3

I also used a build script for my package manager. I simply edited that in order to use the rc.

pkgname=opam
pkgver=2.0.0
_pkgver=rc
pkgrel=1
pkgdesc='OCaml package manager'
arch=('x86_64')
url='http://opam.ocaml.org/'
license=('GPL')
depends=('aspcud' 'ocaml' 'patch' 'unzip')
optdepends=('darcs: For downloading packages with darcs'
            'git: For downloading packages with git'
            'mercurial: For downloading packages with mercurial')
source=("https://github.com/ocaml/opam/archive/$pkgver-$_pkgver.tar.gz")
sha256sums=('0d4ea8c249e18ca2e83e809a20901c7e968e88bdbbacc72105b5a71c6531d17b')

build() {
  cd "opam-$pkgver-$_pkgver"

  ./configure --prefix=/usr
  make -j1 lib-ext all
}

package() {
  make -C "opam-$pkgver-$_pkgver" DESTDIR="$pkgdir-$_pkgver" install
}

#4

Hmm I thought usually package managers also handle env variables. Unfortunately I’m not really familiar with pacman. This is a dumb question, but would starting a new terminal session help?

Also, any reason why you don’t use the given install script? It will download a prebuilt binary, and you don’t need the aspcud and ocaml dependency anymore (aspcud is not necessary since opam2 has builtin solver). The script will also backup the old opam binary so you could just mv it to revert the change.


#5

It turns out, the installed version 1.2.2 is that one from Linuxbrew, it seems like I forgot about that one.

I already did that, so I consider it not as a dumb question :stuck_out_tongue:

Yeah, because of this obscure path message and since everyone is telling you its insecure to install by such scripts.

Oh, I see now what it means with adjusting the path, it simply asks you where you want to install it once launched. Could not hurt to mention that so. Especially since I have not even anything to adjust.

The naming here confused me a bit. ^^

This script at least suggested me to install into the linuxbrew directory, which gave me the hint :wink:

It seems like I messed up the pacman script somehow since it showed zero kb of size on uninstallation.

I guess it installed in the wrong location somehow or so.

Anyway, the script worked so this is solved, thank you.