Opam install fails - ERROR while compiling ocamlfind.1.8.0


having a hard time to get opam working properly on my Linux mint system.

For example: if I try to run
opam install eigen

I am getting following error:
#=== ERROR while compiling ocamlfind.1.8.0 ====================================#

context 2.0.4 | linux/x86_64 | base-bigarray.base base-threads.base base-unix.base ocaml-system.4.10.0+dev0-2019-04-23 | https://opam.ocaml.org/#b209c229

path ~/.opam/system/.opam-switch/build/ocamlfind.1.8.0

command ~/.opam/opam-init/hooks/sandbox.sh build ./configure -bindir /home/florian/.opam/system/bin -sitelib /home/florian/.opam/system/lib -mandir /home/florian/.opam/system/man -config /home/florian/.opam/system/lib/findlib.conf -no-custom -no-topfind

exit-code 1

env-file ~/.opam/log/ocamlfind-7490-548b09.env

output-file ~/.opam/log/ocamlfind-7490-548b09.out


Welcome to findlib version 1.8.0

Configuring core…

Checking for #remove_directory

Testing threading model…

The -vmthread switch is not supported: Your ocaml version is too old!

I have tried with Ocaml 4.10.0 and 4.05.0.

Interestingly when I try:
ocamlc -vmthread

it says:
The -vmthread argument of ocamlc is no longer supported
since OCaml 4.09.0. Please switch to system threads, which have the
same API. Lightweight threads with VM-level scheduling are provided by
third-party libraries such as Lwt, but with a different

Does anyone have an idea how to get Opam working?

Thanks a lot in advance!

OCaml 4.10 is still in development. You should probably use a released version, like 4.08.0 (or 4.08.1+rc2). Normally, installing OCaml 4.05.0 should have worked, or at the very least failed with a different error.

Thanks. You were right with 4.05.0 it is working. My problem was that I had 2 ocaml installations on my system: One in /usr/bin - installed via apt - and another one in /usr/local/bin - installed via" make install".
Removing and purging the installations did the job.