Opam 2 ppa available for Ubuntu Trusty/Xenial/Bionic/Cosmic now

opam
ci

#1

After a couple of requests, I’ve refreshed the opam2 PPA infrastructure to make binary packages available for more variants of Ubuntu for the latest stable release of opam (2.0.2). The new support for Ubuntu Trusty and Xenial builds means that the ppa can be used with Travis CI for non-container based builds. Travis does not currently support Bionic, and so Xenial is the latest available there.

In order to support these older distros, I’ve also packaged up Bubblewrap for the older Ubuntu distributions. This is of course an unofficial backport, so let me know if you run into any problems with it.

The packages currently sit in my PPA tree at avsm/ppa-opam, and can be used by simple adding:

sudo add-apt-repository ppa:avsm/ppa
sudo apt-get update
sudo apt-get -y install opam

to your CI scripts.

Sources to the scripts and more information in the README:

If anyone would like to help with including opam 2 in more upstream distributions, please refer to the distributions wiki and pick your favourite OS :slight_smile: