Ocamldot: backward compatibility / incompatible with ocaml 4.08 +


I have some project making use of


(the library that allows to generate dot/graphviz style graphs:


My ocaml version (under fedora) is 4.08.1. With that, the installation of ocamldot fails (with an older ocaml version on a different machine pool, namely 4.02) it works. What concretely is failing is that
already the


procedure aborts. There are some warning about ``deprecated’’ use of Pervasives, which does not result in the abort. However, related to that, there is a type error which abrorts the configuration, and that seems to be related with the mentioned deprecation of some functionality resp. the replacement.
That aborting is already in the configuration precess (trying to compile a file checkocaml.ml), so no Makefile is generated and I don’t know if there are further incompatibilities down the road.

Anyy suggestions how to proceed?

- try to ``repair'' the confuguration?
  • are there alternatives to ocamldot? The packages seem not to be touched for some time?
  • stdlib-shims? (there is not much documetation about that, though)

Thanks, Martin (and Happy New Year).

Have you tried to use the patch from this PR ?

EDIT: I applied the patch from the above PR and fixed a few things here and it compiles fine.

EDIT 2: I quickly (and partially) switched the project to dune.

thanks a lot for the amazingly fast reply…

I tried to apply the pull request, thouig it’s my first ``pull request’’ ever (though I’ve been working with git quite a bit), so I am not sure what to do exactly. I followed the github instructionx concerning pull requests. trying to follow the steps of


assuming that this it what I should do. However, different from what’s described there, the page when trying to get the ``command line instructions’’ informs me that

 "Only those with write access to this repository can merge pull requests."

So I wonder if I am doing the right thing (resp. whether I am allowed to do that, I assume I don’t have write persmissions).

Sorry for the probably naive question. Martin

You can just clone my repository, on which I applied everything you need and it’ll work directly: git clone https://github.com/zapashcanon/ocamldot.git.

Otherwise, the link is about applying a PR to a repo you own, so it won’t work. You can apply it on a local repo. like this:

git clone https://github.com/zoggy/ocamldot.git
cd ocamldot
wget https://github.com/zoggy/ocamldot/pull/3.patch
git am 3.patch
rm 3.patch

Great, it worked like a breeze (configuration, make, make install, make test) make doc reports an error, but I look into that one first.

I have not testest my own project with it, but with ocamldot up and compiled again, I don’t expect problems.

Thanks again, Martin