Getting errors on WSL trying to install from ppa:avsm/ppa

windows

#1

Hi,

I’m trying to install OCaml on Windows Subsystem for Linux following the instructions on the homepage for Ubuntu. I’m getting the following error:

W: The repository 'http://ppa.launchpad.net/avsm/ppa/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/avsm/ppa/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Has anyone gotten anything like this?


#2

Installing Ocaml+Opam on WSL from this instruction, works:
https://github.com/reasonml/reasonml.github.io/issues/195
Success is limited to Ocaml and Opam though.


#3

Thanks, I made a note of what worked for me at https://github.com/reasonml/reasonml.github.io/issues/195#issuecomment-335048937


#4

Anil Madhavapeddy, the author of “avsm/ppa” told me:

“The good news is that the PPA is no longer necessary, as Ubuntu 16.04 ships with the latest packages.
Have you tried simply apt install opam to get started on WSL?”

Which means, this PPA is outdated and shouldn’t be used anymore!


#5

Ah I see, which means http://ocaml.org/docs/install.html#Ubuntu also needs to be updated :slight_smile: