Error: Unbound module Stdlib with Windows IDE (Camelia, OcalIDE)

On Windows, I try to use ocaml from Camelia or Eclipse/OcalIDE, but I have the following error :

File "command line", line 1: 
Error: Unbound module Stdlib 

The configuration of both IDE are similar : library search path = D:/OCaml64/home/frede/.opam/4.11.1+mingw64c/lib/ocaml. It is the same value than $OCAMLLIB from a Cygwin environment where ocaml or utop are functionnal. It is a curious path for a Cygwin program, but even /home/frede/.opam/4.11.1+mingw64c/lib/ocaml gives the same result.

(If I try the ocaml and its library with version 4.01.0, the error is similar : Fatal error: cannot open implicit module "Pervasives")

I guess I know what append : on error of configuration in Eclipse/OcaIDE.

Camelia seems weird : it unsets the OCAMLLIB environment I have set globally, and uses the path to feed the top level with 2 arguments : -I and “the_ocaml_lib_path”. Unfortunately, the quotes (") are added and make the path invalid. I can however set the toplevel as caml -I ocaml_lib_path.

Are you interested in Eclipse-based IDE in particular? Experience with VsCode on Windows+WSL could be more smooth…

I have tried VSCode on Windows, but the menu “Execute/Execute without debugging” proposes multiple evironments :

Chrome, Edge, Node.js, Ocamlearlybird, Python…

Only Ocamlearlybird is Ocaml related… and it print “Unsupported file format” on a .ml file.

I didn’t manage to execute or compile an Ocaml program in this evironment excepted by typing command in the terminal. I think it is a new subject (How to execute a programme in VSCode+OCaml Platform)