Cannot install packages on Fedora 31

I am trying to install async_extended and merlin on a new installation of Fedora 31 (no other software installed). The commands

sudo dnf install opam
opam init -a
eval $(opam env)
opam install -y async_extended merlin

result in the final command printing

Sorry, no solution found: there seems to be a problem with your request.

Running opam config report gives opam-version: 2.0.4 and solver: builtin-mccs+glpk.

Do I need a different solver? If so, how do I install on Fedora?

Maybe the package list is outdated? Could you try running opam update before the install?

If opam does install the latest OCaml version (4.0.9) then merlin is not yet available for this version.

Try running opam without the -y and with the --verbose option

Running opam update before the package install results in the same error message. Running opam install --verbose merlin results in the same error message. The version of OCaml installed is indeed 4.0.9.

Then you need to wait for this to be merged first