Can you share your secret to make ocsigen-start work?

ocsigen-start.2.9.1
Compilation is ok.
App build is still broken:

$ make test.byte 
eliomdep -server -ppx -ppx "ocsigen-i18n-rewriter Test3_i18n" -package lwt_ppx -package js_of_ocaml-ppx.deriving -package ppx_deriving.std -package pgocaml -package ocsigen-start.server test3_i18n.eliom > _deps/test3_i18n.eliom.server.tmp && mv _deps/test3_i18n.eliom.server.tmp _deps/test3_i18n.eliom.server
File "test3_i18n.eliom", line 228, characters 8-8:
Error: Syntax error
Makefile.os:306: .depend: No such file or directory
make: *** [Makefile.os:322: _deps/test3_i18n.eliom.server] Error 2

We can see that at line 228 the OCaml expression is not complete:

match lang with
| En -> [txt "Hi,\\r\\nTo set a new password, please click on this link: Bonjour,\\r\\nPour mettre \195\160 jour votre mot de passe, cliquez sur ce lien\194\160:"]
| Fr ->

This is not good for Ocsigen beginners (and for normal Ocsigen users).
Can someone from the Ocsigen team give us a feedback about how fixing that?

Indeed a tab is missing in assets/test3_i18n.tsv between english and french version …
Thank you for the report.
I’ll fix that.

I released 2.9.2 with this small fix.
Will be in opam probably as soon as the PR is accepted.

I just added the missing tab in assets/test3_i18n.tsv as in your patch: https://github.com/ocsigen/ocsigen-start/commit/a3ce97bca425220450b20f4ae231cb9a4af15fe1
(I first tried to update the file ~/.opam/4.07.1/.opam-switch/build/ocsigen-start.2.9.1/template.distillery/‘assets!PROJECT_NAME_i18n.tsv’ but it didn’t work)

Now the patched ocsigen-start.2.9.1 web app is up and running.

Let’s wait for opam to be updated with 2.9.2 .
Do you know how this could happen? (deleted tab)
Thanks

1 Like

It is usually fast. But it seems some dependency problem is still to be solved. We are looking into it.

ocsigen-start.2.9.2 has been published today (Nov 28). That’s nearly one week since your PR.
Now compilation of ocsigen-start.2.9.2 is fine.
Ocsigen start web app build is fine too (with enabled lateral menu bar).

Did you find how the tab could be deleted in assets/test3_i18n.tsv (2.9.1)?

Thanks