Build failure with extensions

I am using Easybuild to build OCaml 4.02.3 (YES I know this is out of date). The build fails while adding extensions. I have built the package without any extensions and then tried to add the extensions with the same results. My build host has 32GB of memory. This is the output from the EasyBuild build process:

== building and installing OCaml/4.02.3-foss-2016b…
== fetching files…
== creating build dir, resetting environment…
== unpacking…
== patching…
== preparing…
== configuring…
== building…
== testing…
== installing…
== taking care of extensions…
== installing extension ocamlfind 1.8.0 (1/2)…
== installing extension gsl 1.18.5 (2/2)…
== FAILED: Installation ended unsuccessfully (build directory: /app/easybuild/build/OCaml/4.02.3/foss-2016b): build failed (first 300 chars): cmd “eval opam config env && opam install -yv gsl.1.18.5” exited with exit code 1 and output:
‘opam install -yv gsl.1.18.5’ failed.
Fatal error:
Stack overflow

Building Ocam-4.02.3 with ocamlfind 1.8.0 was an incompatible combination. After downgrading ocamlfind to version to 1.5.5, gsl loaded without a “Stack overflow”. Stack Overflow is not an error message one would expect when using an incompatible library issue.